A note on Android SDK 2.3.3 API level 10

NOTE: This blog post was originally hosted on Motorola's MOTODEV web site. That site was decommissioned in 2012. I've made every attempt to preserve blog posts and accompanying forum posts with their original content. Many web links are no longer valid, so they have been removed and replaced with emphasized text.

by Eric Cloninger (EricC)

Google released a new version of their SDK today for API level 10, targeting platform 2.3.3 (Gingerbread). There is a thread covering the topic at the MOTODEV discussion boards.

http://community.developer.motorola.com/t5/MOTODEV-Studio-for-Android/Android-SDK-2-3-3-with-API-lev...


>>>> Content of Discussion Board Post <<<<

Google released a new version of their SDK today for API level 10, targeting platform 2.3.3 (Gingerbread). You can find it with the Android SDK and AVD manager tool that ships with the Android SDK. There is not a corresponding release of the ADT plugins for Eclipse/MOTODEV Studio.

We've done some preliminary tests and we haven't seen any obvious problems with using the SDK with MOTODEV Studio 2.1. We will do some more testing over the next few days, but you can probably start using the 2.3.3 SDK to build and test your apps. If we find problems, I will post them to this thread.

Thank you for using MOTODEV Studio.

-E